Функция СЧИТАТЬПУСТОТЫ() в EXCEL

Что возвращает функция

Возвращает количество пустых ячеек в заданном диапазоне.

Синтаксис

=COUNTBLANK(range) – английская версия

=СЧИТАТЬПУСТОТЫ (диапазон) – русская версия

Проверка заполнения данными таблицы с помощью функции СЧЁТЗ в Excel

Пример 2. Для решения спорных ситуаций в случае ДТП в Excel была создана форма для расчета тормозного пути автомобиля. Таблица содержит 4 поля данных, являющихся обязательными для заполнения. Реализовать алгоритм выведения ошибки «Указаны не все данные» в случае, если для расчета не хватает данных.

Исходная таблица:

Функция, которая будет выводить ошибку, если не все данные введены:

=ЕСЛИ(СЧЁТЗ(A2:A5)<>СЧЁТЗ(B2:B5);”Указаны не все данные”;B4*0,28*B5+(СТЕПЕНЬ(B4*0,28;2)/(2*B3*B2)))

В столбце A:A содержатся пояснения к данным, находящимся в соседнем столбце. Если число заполненных ячеек в A2:A5 и B2:B5 совпадают, будет выполнен расчет по формуле B4*0,28*B5+(СТЕПЕНЬ(B4*0,28;2)/(2*B3*B2)), иначе будет выведена информация об ошибке. В данном случае все поля указаны и заполнены. Результат:

Если, например, время реакции не указано, будет выведен следующий результат:

Подсчет всех пустых и непустых ячеек в диапазоне с числами и без

Как посчитать количество непустых и пустых ячеек в диапазоне Excel?

После написания бизнес-плана запуска и реализации проекта фирмы был составлен график активности выполненных действий, которые очень важно выполнить на начальных этапах. На против каждой даты в графике следует заполнять выполненные важные действия. Если сделка переносилась на другую дату и в этот день не было времени и возможности завершить запланированную задачу, тогда поле остается пустым и не заполоняться. Для отчетности по активности реализации проекта за определенный период времени необходимо контролировать динамику и уровень активности руководителя фирмы. Схематический график заполнения выпаленными действиями с готовым результатом выглядит следующим образом:

Для контроля динамики и уровня активности определим процент результативных ней за данный период времени. Для этого нам нужно суммировать все активные дни и разделить их на суммарное количество всех дней (активных + пассивных) за данный период времени. Используем формулу:

=СЧЁТЗ(B3:B16)/(СЧЁТЗ(B3:B16)+СЧИТАТЬПУСТОТЫ(B3:B16))

В результате получим:

Немного изменим формулу, чтобы посчитать долю в процентах пассивных дней, которая не должна превышать 50-ти процентов для реализации проекта в заранее установленные сроком:

=СЧИТАТЬПУСТОТЫ(B3:B16)/(СЧЁТЗ(B3:B16)+СЧИТАТЬПУСТОТЫ(B3:B16))

А после добавим соответствующую гистограмму для визуального анализа и контроля:

Как посчитать количество пустых ячеек Excel? Функция СЧИТАТЬПУСТОТЫ

Пустые ячейки не считаются многими формулами, например, при расчете среднего значения функцией СРЗНАЧ пустая ячейка не учитывается (необходимо заменить на 0). Соответственно существуют специальные формулы для подсчета именно незаполненных ячеек.

Считаем количество пустых ячеек функцией СЧИТАТЬПУСТОТЫ

В формуле необходимо задать диапазон, как показано на картинке

=СЧИТАТЬПУСТОТЫ(A2:A6)

Такая формула выдаст значение = 3.

Считаем количество пустых ячеек функцией СЧЁТЕСЛИ

В версиях Excel ниже 2007 не было функции СЧИТАТЬПУСТОТЫ, поэтому мы часто пользовались СЧЁТЕСЛИ.

Запишем формулу для того же диапазона

=СЧЁТЕСЛИ(A2:A6;"")

Список задач

Даже самая светлая голова при ясном уме и твёрдой памяти однажды даст сбой, и вы что-то забудете. Хорошо, если это будет покупка корма для рыбок, поздравление тёщи с Днём матери или поливка фиалки вашей второй половинки. Они побулькают, пошипят и поквакают, а ваша совесть останется чистой. Но вдруг вы не оплатите предмет первой необходимости — интернет? Вам будет стыдно смотреть на себя в зеркало. И в тот злополучный день вы сломаетесь и пообещаете составлять списки дел. А пока вы будете мучиться выбором среди электронных планировщиков, попробуйте начать с простого перечня задач.

Назначайте задания, устанавливайте им приоритет, задавайте дедлайн, выбирайте ответственное лицо, следите за прогрессом выполнения и оставляйте заметки, не выходя из Excel. Шаблон уже настроен на быструю сортировку по дате, важности, статусу и другим параметрам.

Бюджет путешествия

Теоретически даже самое нереальное (и при этом полноценное) путешествие может обойтись вообще без финансовых вложений с вашей стороны. Для этого необходимо заручиться поддержкой на краудфандинговой площадке, найти бесплатные места для посещения и немного поработать за еду и койко-место. Такие успехи сопутствуют лишь прожжённым путешественникам с изрядной долей везения. Хотя чего таить, даже им приходится искать пару монет на звонок, чтобы отчитаться маме о своём здравии. Поэтому любое перемещение за границы места проживания сопровождается предварительным планированием и составлением сметы. И дабы вам не пришлось марать листки бумаги и без конца крутить-вертеть цифры, предлагаем обратиться за помощью к калькулятору поездки.

Помимо самого расчёта, шаблон умеет отображать предполагаемые траты в виде круговой диаграммы. Разбиение денежек на категории в процентном отношении даст понять, какая статья расходов наиболее прожорлива.

Инвентарный список

Что объединяет пожар, потоп, кражу и приезд родни погостить «на недельку»? Правильно, высокая вероятность утраты целостности вашего имущества.

Уж такова человеческая натура, что жаба душит не за сам факт утери бабушкиных носков, а за то, что вы вообще не можете припомнить весь свой накопленный скарб. При таких неблагоприятных раскладах вас выручит опись домашней утвари. А в дополнение к ней не лишним будет и сфотографировать свои хоромы со всем содержимым.

Отставив шутки, можно посоветовать шаблон тем людям, которые сдают жильё. Принимая постояльцев на долгий срок заселения, не забудьте ознакомить их под роспись с актом проведённой инвентаризации. Он сослужит вам добрую службу при выселении арендаторов.

Источники


  • https://excelhack.ru/funkciya-countblank-schitatpustoti-v-excel/
  • https://exceltable.com/funkcii-excel/primery-funkciy-schetz-i-schitatpustoty
  • https://excelworks.ru/2017/06/10/kolichestvo-pustyih-yacheek/
  • https://Lifehacker.ru/excel-na-kazhdy-j-den/

Рейтинг
( Пока оценок нет )
Понравилась статья? Поделиться с друзьями:
Все об Экселе: формулы, полезные советы и решения