ОКРУГЛ (ROUND) округление значений в Excel

Содержание
  1. Как числа хранятся в Excel и отображаются на экране
  2. Настройка отображения чисел через панель инструментов
  3. Формат чисел через контекстное меню
  4. Как округлить число функцией ОКРУГЛ
  5. Как округлить число в Excel – Как округлить число до десятых
  6. Как округлить число в Excel – Как округлить число до сотых
  7. Как округлить число в Excel – Как округлить число до тысячных
  8. Как округлить число до десятков
  9. Как округлить число до сотен
  10. Как округлить число до тысяч
  11. ОКРВВЕРХ.МАТ и ОКРВНИЗ.МАТ
  12. Изменение количества отображаемых знаков после запятой без изменения числового значения
  13. Задать точность как на экране
  14. Примеры использования функций округления
  15. Округление в большую сторону в Эксель
  16. Округление в Excel с помощью функции ОКРУГЛ
  17. Синтаксис
  18. Аргументы функции
  19. Основы использования функции
  20. Формула ОКРУГЛВНИЗ() или ROUNDDOWN()
  21. Формула ОКРГУЛТ() или MROUND()
  22. Как округлить до целого числа в Excel?
  23. Округление с помощью кнопок на ленте
  24. Установка точности расчетов

Как числа хранятся в Excel и отображаются на экране

Программа Excel умеет работать с двумя типами чисел: точными и приблизительными. Пользователь может выбирать способ их отображения, однако, в самой программе число хранится в точном виде (до 15 знаков после запятой). Поэтому, даже если на экране число будет отображаться до двух знаков после запятой, при расчетах программа будет обращаться к гораздо более точной записи в памяти.

Пользователь может настроить то, как это число будет показано на экране. А округление происходит по общепринятым нормам: числа от 0 до 4 включительно округляются вниз, а с 5 до 9 – вверх.

Настройка отображения чисел через панель инструментов

Самый простой способ округлить число, а точнее, его отображения на экране – через кнопки на Панели инструментов. Чтобы найти их, должна быть открыта вкладка “Главная”, в которой расположен подраздел “Число”. Здесь и находятся требуемые функции “Увеличить разрядность” или “Уменьшить разрядность”.

Выберите ячейку с числом и нажмите на кнопку с нужным действием. Функция “Увеличить разрядность” будет добавлять в конец дробной части нули.

Функция “Уменьшить разрядность” будет убирать цифры с конца, округляя окончания.

Примечание: Важно помнить, что числовое значение, которое хранится в памяти программы после проделанных действий никак не изменится, и расчеты будут производиться с исходным значением.

Формат чисел через контекстное меню

Нужную степень отображаемого на экране округления можно изменить и другим способом – через контекстное меню ячейки.

  1. Выделяем нужную ячейку (или область, состоящую из нескольких ячеек) и кликаем по ней правой кнопкой мыши. В контекстном меню выбираем пункт “Формат ячеек…”.
  2. Откроется окно, в котором в верхнем меню переходим во вкладку “Число” (по умолчанию должна быть установлена именно эта вкладка). В списке слева выбираем “Числовой” формат. Справа находим надпись “Число десятичных знаков”, рядом с которым есть текстовое поле для выбора количества знаков дробной части. Можно ввести его самостоятельно или дойти до нужного значения путем нажатия на стрелки вверх или вниз.
  3. Далее нажимаем на “ОК”, после чего изменения вступят в силу.

Примечание: Также можно поставить галочку напротив надписи “Разделитель групп разрядов”, чтобы при отображении больших чисел разграничить группы разрядов.

Как округлить число функцией ОКРУГЛ

ОКРУГЛ – это основная функция округления чисел в Excel, которая округляет число до указанного количества знаков.

Синтаксис:

Число – любое действительное число, которое вы хотите округлить. Это может быть число или ссылка на ячейку.

Число_разрядов – количество знаков для округления числа. Вы можете указать положительное или отрицательное значение в этом аргументе:

  • Если число_разрядов больше 0, число округляется до указанного количества десятичных знаков. Например, =ОКРУГЛ(17,25; 1) округляет число 17,25 до 17,3.

Чтобы округлить число до десятых, укажите в аргументе число_разрядов значение равное 1.

Как округлить число в Excel – Как округлить число до десятых

Если необходимо округлить число до сотых, задайте аргумент число_разрядов равным 2.

Как округлить число в Excel – Как округлить число до сотых

Для того чтобы округлить число до тысячных, введите 3 в число_разрядов.

Как округлить число в Excel – Как округлить число до тысячных

  • Если число_разрядов меньше 0, все десятичные разряды удаляются, а число округляется слева от десятичной точки (до десятых, до сотен, до тысяч и т. д.). Например, =ОКРУГЛ(17,25; -1) округляет 17,25 к ближайшему кратному 10 числу и возвращает в результате 20.
  • Если число_разрядов равно 0, число округляется до ближайшего целого числа (без десятичных знаков). Например, =ОКРУГЛ(17,25; 0) округляет 17,25 до 17.

На следующем изображении демонстрируются несколько примеров, как округлить число в Excel в формуле ОКРУГЛ:

Как округлить число до десятков

Правило округления числа до десятков

Чтобы округлить число до десятков, нужно цифру в разряде единиц заменить нулем, а если в записи числа есть цифры после запятой, то их следует отбросить.

Если первая из отброшенных цифр 0, 1, 2, 3 или 4, то предыдущую цифру не изменяем.

Если первая из отброшенных цифр 5, 6, 7, 8 или 9, то предыдущую цифру увеличиваем на единицу.

Примеры округления числа до десятков:

Чтобы округлить число до десятков, цифру в разряде единиц (то есть последнюю цифру в записи натурального числа) заменяем нулем. Так как эта цифра равна 3, предыдущую цифру не изменяем. Читают: «Пятьсот восемьдесят три приближенно равно пятьсот восемьдесят».

Округляем до десятков, поэтому цифру в разряде единиц заменяем на нуль. Поскольку эта цифра — 7, предыдущую увеличиваем на единицу. Читают: «Тысяча тридцать семь приближенно равно тысяча сорок».

Округляя десятичную дробь до десятков, цифру в разряде единиц (то есть последнюю цифру перед запятой) заменяем нулем, а запятую и все стоящие после нее цифры отбрасываем. Замененная на нуль цифра — 2, значит предыдущую цифру изменять не надо. Читают: «Триста пятьдесят две целых семьдесят восемь сотых приближенно равно триста пятьдесят».

Чтобы округлить данную десятичную дробь до десятков, цифру в разряде единиц заменяем нулем, а цифры, стоящие после запятой, отбрасываем. Так как замененная нулем цифра равна 6, к предыдущей цифре прибавляем единицу. Читают: «Две тысячи четыреста семьдесят шесть целых пять сотых приближенно равно две тысячи четыреста восемьдесят».

Округляя десятичную дробь до десятков, в разряде единиц заменяем цифру нулем, а запятую и все, что стоит после запятой, отбрасываем. Поскольку на нуль заменили 9, то предыдущую цифру увеличиваем на единицу. Читают: «Семьсот девяносто девять целых, одна десятая приближенно равно восемьсот».

Как округлить число до сотен

Правило округления числа до сотен

Чтобы округлить число до сотен, надо цифры в разряде единиц и десятков заменить нулями. При округлении до сотен десятичной дроби запятую и все стоящие после нее цифры отбрасывают.

Если первая из отброшенных цифр 0, 1, 2, 3 или 4, то предыдущую цифру не изменяем.

Если первая из отброшенных цифр 5, 6, 7, 8 или 9, то предыдущую цифру увеличиваем на единицу.

Примеры округления числа до сотен:

Чтобы округлить до сотен это число, цифры в разряде единиц и десятков (то есть две последние цифры в записи) заменяем нулями. Так как первая из замененных на нуль цифр равна 1, предыдущую цифру не изменяем. Читают: «Две тысячи триста семнадцать приближенно равно две тысячи триста».

Округляя данное число до сотен, две последние цифры в его записи заменяем на нули. Поскольку первая из замененных нулем цифр равна 8, предыдущую цифру увеличиваем на единицу. Читают: «Четыре тысячи пятьсот восемьдесят один приближенно равно четыре тысячи шестьсот».

Округляем число до сотен, значит две последние цифры в записи числа — десятки и единицы — заменяем нулями. Первая из замененных нулем цифр равна нулю, поэтому предыдущую переписываем без изменений. Читают: «Семьдесят восемь тысяч пятьсот девять приближенно равно семьдесят восемь тысяч пятьсот».

Чтобы округлить до сотен данное число, в разрядах десятков и единиц цифры заменяем на нули. Так как первая из замененных на нуль цифр — 9, предыдущую увеличиваем на единицу. Читают: «Девяносто три тысячи девятьсот пятьдесят два приближенно равно девяносто четыре тысячи».

Чтобы округлить до сотен десятичную дробь, запятую и все стоящие после запятой цифры необходимо отбросить, а две последние цифры целой части (единицы и десятки) — заменить нулями. Первая из замененных на нуль цифр равна 7, поэтому к предыдущей цифре прибавляем единицу. Читают: «Тысяча четыреста семьдесят три целых двенадцать сотых приближенно равно тысяча пятьсот».

Как округлить число до тысяч

Правило округления числа до тысяч

Чтобы округлить число до тысяч, надо цифры в разрядах сотен, десятков и единиц заменить нулями. При округлении до тысяч десятичной дроби запятую и все стоящие после нее цифры нужно отбросить.

Если первая из отброшенных цифр 0, 1, 2, 3 или 4, то предыдущую цифру не изменяем.

Если первая из отброшенных цифр 5, 6, 7, 8 или 9, то предыдущую цифру увеличиваем на единицу.

Примеры округления числа до тысяч :

Чтобы округлить до тысяч это число, надо цифры в разрядах сотен, десятков и единиц заменить нулями (у тысяч три нуля в конце записи, столько же нулей в конце числа должно получиться и при округлении до тысяч). Так как первая из цифр, которую мы заменили на нуль, равна 3, то предыдущую цифру оставляем без изменений. Читают: «Восемьдесят две тысячи триста семьдесят один приближенно равно восемьдесят две тысячи».

При округлении до тысяч три последних цифры — в разрядах сотен, десятков и единиц — заменяем на нули. Так как первая из замененных нулем цифр равна 6, предыдущую цифру увеличиваем на единицу. Читают: «Сорок тысяч шестьсот двадцать восемь приближенно равно сорок одна тысяча».

Округляя до тысяч данное число, цифры в разрядах сотен, десятков и единиц заменяем нулями. Первая из замененных нулем цифр равна 7, поэтому к предыдущей цифре прибавляем единицу. Читают: «Сто пятьдесят девять тысяч семьсот тридцать два приближенно равно сто шестьдесят тысяч».

Округляем число до тысяч, поэтому цифры в разрядах сотен, десятков и единиц заменяем на нули. Так как первая из цифр, которую мы заменили нулем, равна 1, то предыдущую цифру переписываем без изменений. Читают: «Двести тридцать восемь тысяч сто девяносто семь приближенно равно двести тридцать восемь тысяч».

Чтобы округлить десятичную дробь до тысяч, запятую и все цифры после запятой отбрасываем, а цифры в разрядах сотен, десятков и единиц заменяем нулями. Так как первая из замененных нулем цифр — 2, то предыдущую цифру не изменяем. Читают: «Четыреста пятьдесят семь тысяч двести сорок девять целых, восемьдесят три сотых приближенно равно четыреста пятьдесят тысяч».

ОКРВВЕРХ.МАТ и ОКРВНИЗ.МАТ

Округление с заданной точностью также можно производить принудительно вверх или вниз с помощью ОКРВВЕРХ.МАТ и ОКРВНИЗ.МАТ. Например, при расчете заказа, когда никак нельзя заказать меньше расчетного объема, но при этом нужно и кратность сохранить. То есть одна «лишняя» штука требует заказа дополнительно целого ящика. Аргументы функции те же.

Это были основные формулы округления в Excel. Но есть еще парочку, которые используются реже.

Функция ЦЕЛОЕ в Excel отбрасывает дробную часть и таким образом округляет вниз до ближайшего целого. Будет полезна при расчете целого количество лет между датами (возраст человека).

Функции ЧЁТН и НЕЧЁТ округляют числа до ближайшего четного или нечетного значения соответственно.

Изменение количества отображаемых знаков после запятой без изменения числового значения

Выполнение такого рода действия осуществляется при помощи настроек числового формата, путем уменьшения количества знаков после запятой, при этом само числовое значение не округляется, округляется только его отображение на экране монитора. Внести изменения в настройки числового формата, можно при помощи кнопок «Увеличить разрядность» и «Уменьшить разрядность» на ленте Excel 2007 во вкладке «Главная», в группе «Число».

В других версиях Excel эти кнопки выглядят аналогично. Изменения в настройки числового формата, а именно увеличение либо уменьшение количества отображаемых знаков после запятой, можно внести в настройках формата ячеек. Не буду повторять о том, как вызвать окно “Формат ячеек” разными способами, так как ранее этот вопрос уже рассматривался. Использование вышеописанного метода округления может приводить к некоторым нежелательным последствиям, например вот к такому:

Как видно из примера, некорректная настройка числового формата привела к тому, что 2+3=6, что неверно.

Задать точность как на экране

Следует отметить еще одну возможность Excel, заложенную в параметрах Excel, в разделе «Дополнительно», в группе «При пересчете этой книги» – это пункт «Задать точность как на экране».

*Применение опции “Задать точность как на экране” ведет к изменению числовых значений и точности вычислений.

Примеры использования функций округления

=ОКРУГЛ(1,475;2) Округляет число 1,475 до двух десятичных разрядов, в результате получается 1,48;

=ОКРУГЛВВЕРХ(3,14159;3) Округляет с избытком число 3,14159 до трех десятичных разрядов, результат 3,142;

=ОКРУГЛВНИЗ(3,14159) Округляет с недостатком число 3,14159 до трех десятичных разрядов, результат 3,141;

=ОКРУГЛТ(10;3) Округляет число 10 до ближайшего числа, кратного 3, то есть до 9;

=ОКРВВЕРХ(2,5;1) Округляет число 2,5 до ближайшего большего числа, кратного 1, то есть до 3;

=ОКРВНИЗ(2,5;1) Округляет число 2,5 до ближайшего меньшего числа, кратного 1, то есть до 2.

Для того, чтобы избежать возможных неточностей и ошибок, следует тщательно подбирать форматы и способы округления при формировании таблиц в Excel. Если же таблицы уже сформированы не совсем так, как вам бы этого хотелось, то табличные данные можно программно обработать средствами VBA, прибегнув к помощи макросов.

Округление в большую сторону в Эксель

Чтобы самостоятельно регулировать то, до какого значения будет происходить превращение и выбирать большую сторону потребуется использовать формулу:

=ОКРУГЛВВЕРХ(A3;0)

Округление в Excel с помощью функции ОКРУГЛ

Функция ОКРУГЛ часто используется в Excel для округления чисел. С ее помощью вы можете задать количество чисел после запятой.

Синтаксис

=ОКРУГЛ(число;число_разрядов)

Аргументы функции

  • число – числовое значение, которое вы хотите округлить;
  • число_разрядов – значение десятичного разряда, до которого вы хотите округлить первый аргумент функции.

Основы использования функции

  • если аргумент число_разрядов больше “0”, то число округляется до указанного количества десятичных знаков. Например, =ОКРУГЛ(500,51;1) вернет “500.5”;
  • если аргумент число_разрядов равен “0”, то число округляется до ближайшего целого числа. Например, =ОКРУГЛ(500,51;0) вернет “501”;
  • если аргумент число_разрядов меньше “0”, то число округляется влево от десятичного значения. Например, =ОКРУГЛ(500,51;-1) вернет “501”.

Функция ОКРУГЛ работает на основе математического правила, по которому она определяет в большую или меньшую сторону следует округлить число:

  • Если число после запятой равно от 0 до 4, то округление будет произведено в меньшую сторону;
  • Если число после запятой равно от 5 до 9, то функция округлит в большую сторону.

Формула ОКРУГЛВНИЗ() или ROUNDDOWN()

Как в предыдущем примере, только округление последнего разряда будет в меньшую сторону. По идеи в нашем примере от функции ОКРУГЛ() должны отличаться цифры №2 и 3.

Формула ОКРГУЛТ() или MROUND()

Но есть еще одна функция округления это функция ОКРУГЛТ() или MROUND(). Она позволяет найти ближайшее большее число кратное точности.

В строке функций начинаем набирать формулу =ОКРУГЛТ() и нажимаем Fx. В окне аргументов вводим число и укажем точность равной 3

Для первого числа ответ 9. Это ближайшее большеечисло кратное цифре 3.

Как округлить до целого числа в Excel?

Чтобы округлить до целого в большую сторону используем функцию «ОКРУГЛВВЕРХ». Чтобы округлить до целого в меньшую сторону используем функцию «ОКРУГЛВНИЗ». Функция «ОКРУГЛ» и формата ячеек так же позволяют округлить до целого числа, установив количество разрядов – «0» (см.выше).

В программе Excel для округления до целого числа применяется также функция «ОТБР». Она просто отбрасывает знаки после запятой. По сути, округления не происходит. Формула отсекает цифры до назначенного разряда.

Сравните:

Второй аргумент «0» – функция отсекает до целого числа; «1» – до десятой доли; «2» – до сотой доли и т.д.

Специальная функция Excel, которая вернет только целое число, – «ЦЕЛОЕ». Имеет единственный аргумент – «Число». Можно указать числовое значение либо ссылку на ячейку.

Недостаток использования функции «ЦЕЛОЕ» – округляет только в меньшую сторону.

Округлить до целого в Excel можно с помощью функций «ОКРВВЕРХ» и «ОКРВНИЗ». Округление происходит в большую или меньшую сторону до ближайшего целого числа.

Пример использования функций:

Второй аргумент – указание на разряд, до которого должно произойти округление (10 – до десятков, 100 – до сотен и т.д.).

Округление до ближайшего целого четного выполняет функция «ЧЕТН», до ближайшего нечетного – «НЕЧЕТ».

Пример их использования:

Округление с помощью кнопок на ленте

Самый простой способ изменить округление — это выделить ячейку или группу ячеек и, находясь на вкладке «Главная», нажать на ленте на кнопку «Увеличить разрядность» или «Уменьшить разрядность». Обе кнопки располагаются в блоке инструментов «Число». Будет округляться только отображаемое число, но для вычислений при необходимости будут задействованы до 15 разрядов чисел.

При нажатии на кнопку «Увеличить разрядность» количество внесенных знаков после запятой увеличивается на один.

Кнопка «Уменьшить разрядность», соответственно, уменьшает на одну количество цифр после запятой.

Установка точности расчетов

Если в предыдущих случаях устанавливаемые параметры влияли только на внешнее отображения данных, а при расчетах использовались более точные показатели (до 15 знака), то сейчас мы расскажем, как изменить саму точность расчетов.

  1. Перейдите на вкладку «Файл», оттуда — в раздел «Параметры».
  2. Откроется окно параметров Excel. В этом окне зайдите в подраздел «Дополнительно». Отыщите блок настроек под названием «При пересчете этой книги». Настройки в этом блоке применяются не к одному листу, а к книге в целом, то есть ко всему файлу. Поставьте галочку напротив параметра «Задать точность как на экране» и нажмите «OK».
  3. Теперь при расчете данных будет учитываться отображаемая величина числа на экране, а не та, которая хранится в памяти Excel. Настройку же отображаемого числа можно провести любым из двух способов, о которых мы говорили выше.
Источники


  • https://MicroExcel.ru/okrugleniye-chisel/
  • https://naprimerax.org/posts/89/kak-okrugliat-chisla-v-excel
  • https://calcsbox.com/post/okruglenie-cisel.html
  • https://statanaliz.info/excel/funktsii-i-formuly/okruglenie-chisel-v-excel/
  • http://macros-vba.ru/nadstrojki/excel/99-chislovoj-format-yacheek-okruglenie-v-excel
  • https://zen.yandex.ru/media/id/5d3b5f5f31878200ae832ee2/formuly-okrugleniia-chisle-v-excel-5ea7d5a36c197b5e73e56070
  • https://excelhack.ru/okruglenie-v-excel/
  • https://excelinfo.ru/formulas/formula-okrugleniya
  • https://exceltable.com/funkcii-excel/kak-okruglyat-chisla
  • https://lumpics.ru/rounding-numbers-in-excel/

Рейтинг
( Пока оценок нет )
Понравилась статья? Поделиться с друзьями:
Все об Экселе: формулы, полезные советы и решения