Примеры формул с логическими функциями ИСТИНА ЛОЖЬ и НЕ в Excel

Что такое ИСТИНА и ЛОЖЬ в Эксель

ИСТИНА в Excel — это логическое значение, говорящее о том, что условие выполняется. Например, «10>5» – это ИСТИНА.

ЛОЖЬ в Экселе – значение, указывающее, что условие не выполняется. То есть, «10<5» — это ЛОЖЬ.

С помощью функций ИСТИНА() и ЛОЖЬ(), можно явно указать программе, что вы собираетесь использовать эти логические значения.

На базе этих двух показателей строится работа некоторых функций. Теперь о том, какая простейшая логика есть в Excel.

Как проверить в Экселе выполнение нескольких условий

Задача: есть несколько условий. Нужно проверить, истинны ли они. Сейчас, одновременно. Используем функцию И(условие 1условие 2условие n). Такая функция вернет истину, только если все переданные ей условия выполнятся. Смотрим на примере:

Результат Условия 1

Результат Условия 2

Результат функции

И

ИСТИНА

ИСТИНА

ИСТИНА

ИСТИНА

ЛОЖЬ

ЛОЖЬ

ЛОЖЬ

ИСТИНА

ЛОЖЬ

ЛОЖЬ

ЛОЖЬ

ЛОЖЬ

То же в реальных расчетах. В таблице проверяется, чтобы Значение 1 было больше 20, а Значение 2 было равно «+». Ложные результаты, для удобства, выделены красным:

Что делает функция ЕСЛИ?

Она позволяет создать дерево решений, в котором при выполнении какого-то условия происходит определенное действие. А если это условие не выполняется, то совершается другое действие.

При этом аргумент функции должен быть вопросом, на который возможно 2 варианта ответа: «да» и «нет», “истина” или “ложь”.

Вот как может выглядеть это дерево решений.

Итак, функция ЕСЛИ позволяет задать вопрос и указать на 2 варианта вычислений в зависимости от полученного на него ответа. Они и являются тремя аргументами функции.

Синтаксис функции ЕСЛИ

Вот как выглядит синтаксис этой функции и её аргументы:

=ЕСЛИ(логическое выражение, значение если «да», значение если «нет»)

Логическое выражение – (обязательное) условие, которое возвращает значение «истина» или «ложь» («да» или «нет»);

Значение если «да» – (обязательное) действие, которое выполняется в случае положительного ответа;

Значение если «нет» – (обязательное) действие, которое выполняется в случае отрицательного ответа;

Давайте вместе подробнее рассмотрим эти аргументы.

Первый аргумент – это логический вопрос. И ответ этот может быть только «да» или «нет», «истина» или «ложь».

Как правильно задать вопрос? Для этого можно составить логическое выражение, используя знаки “=”, “>”, “<”, “>=”, “<=”, “<>”. Давайте попробуем задать такой вопрос вместе.

Простейший пример применения.

Предположим, вы работаете в компании, которая занимается продажей шоколада в нескольких регионах и работает с множеством покупателей.

Нам необходимо выделить продажи, которые произошли в нашем регионе, и те, которые были сделаны за рубежом. Для этого нужно добавить в таблицу ещё один признак для каждой продажи – страну, в которой она произошла. Мы хотим, чтобы этот признак создавался автоматически для каждой записи (то есть, строки).

В этом нам поможет функция ЕСЛИ. Добавим в таблицу данных столбец “Страна”. Регион “Запад” – это местные продажи («Местные»), а остальные регионы – это продажи за рубеж («Экспорт»).

Как правильно записать?

Устанавливаем курсор в ячейку G2 и вводим знак “=”. Для Excel это означает, что сейчас будет введена формула. Поэтому как только далее будет нажата буква “е”, мы получим предложение выбрать функцию, начинающуюся этой буквы. Выбираем “ЕСЛИ”.

Далее все наши действия также будут сопровождаться подсказками.

В качестве первого аргумента записываем: С2=”Запад”. Как и в других функциях Excel, адрес ячейки можно не вводить вручную, а просто кликнуть на ней мышкой. Затем ставим “,” и указываем второй аргумент.

Второй аргумент – это значение, которое примет ячейка G2, если записанное нами условие будет выполнено. Это будет слово “Местные”.

После этого снова через запятую указываем значение третьего аргумента. Это значение примет ячейка G2, если условие не будет выполнено: “Экспорт”. Не забываем закончить ввод формулы, закрыв скобку и затем нажав “Enter”.

Наша функция выглядит следующим образом:

=ЕСЛИ(C2=”Запад”,”Местные”,”Экспорт”)

Наша ячейка G2 приняла значение «Местные».

Теперь нашу функцию можно скопировать во все остальные ячейки столбца G.

А если один из параметров не заполнен?

Если вас не интересует, что будет, к примеру, если интересующее вас условие не выполняется, тогда можно не вводить второй аргумент. К примеру, мы предоставляем скидку 10% в случае, если заказано более 100 единиц товара. Не указываем никакого аргумента для случая, когда условие не выполняется.

=ЕСЛИ(E2>100,F2*0.1)

Что будет в результате?

Насколько это красиво и удобно – судить вам. Думаю, лучше все же использовать оба аргумента.

И в случае, если второе условие не выполняется, но делать при этом ничего не нужно, вставьте в ячейку пустое значение.

=ЕСЛИ(E2>100,F2*0.1,””)

Однако, такая конструкция может быть использована в том случае, если значение «Истина» или «Ложь» будут использованы другими функциями Excel в качестве логических значений.

Обратите также внимание, что полученные логические значения в ячейке всегда выравниваются по центру. Это видно и на скриншоте выше.

Более того, если вам действительно нужно только проверить какое-то условие и получить «Истина» или «Ложь» («Да» или «Нет»), то вы можете использовать следующую конструкцию –

=ЕСЛИ(E2>100,ИСТИНА,ЛОЖЬ)

Обратите внимание, что кавычки здесь использовать не нужно. Если вы заключите аргументы в кавычки, то в результате выполнения функции ЕСЛИ вы получите текстовые значения, а не логические.

Использование функции ЕСЛИ с числами.

Точно так же, как мы это делали с текстом, в аргументах функции можно использовать и числа.

Однако для нас важно то, что функция ЕСЛИ позволяет не только заполнять ячейки определёнными числовыми значениями в зависимости от выполнения условия, но также и производить некоторые вычисления.

К примеру, мы предоставляем нашему покупателю скидку в зависимости от суммы покупки. Если сумма больше 100, то он получает скидку 10%.

Назовём столбец Н “Скидка” и в ячейку H2 введём функцию ЕСЛИ, вторым аргументом которой будет формула расчёта скидки.

=ЕСЛИ(E2>100,F2*0.1,0)

Аргументы функции

Аргументы в функции не используются.

Дополнительная информация

  • Функцию лучше всего использовать, когда вы оцениваете условие, и если оно не равно логическому значению TRUE, вы просто хотите получить значение FALSE в ячейке. Например:

=IF(AND(A1>0,A1<100),”Approve”,FALSE()) – английская версия

=ЕСЛИ(И(A1>0;A1<100);”Одобрить”;ЛОЖЬ()) – русская версия

  • В этом примере, если условие формулы не выполняется, то функция просто возвращает FALSE (ЛОЖЬ) в качестве результата;
  • Если вы введете FALSE (ЛОЖЬ) (без круглых скобок) в формулу или ячейку, Excel автоматически примет ее как логическое значение FALSE (ЛОЖЬ)
  • FALSE (ЛОЖЬ) и FALSE () (ЛОЖЬ ()) возвращают при использовании одно и то же значение;
  • Вы также можете использовать FALSE (ЛОЖЬ) и TRUE (ИСТИНА) в качестве аргументов. Так FALSE по умолчанию равно “0”, TRUE равно “1”. Например формула =FALSE + FALSE будет равна “0”, а =FALSE + TRUE ,будет равна “1”.

Как посчитать среднее значение по условию в Excel

Пример 2. Определить средний балл за экзамен для группы студентов, в составе которой есть студенты, которые его провалили. Так же необходимо получить среднюю оценку успеваемости только лишь для тех студентов, которые сдали экзамен. Оценка студента, не сдавшего экзамен, должна учитываться как 0 (нуль) в формуле для расчета.

Таблица данных:

Для заполнения столбца «Сдал» используем формулу:

Результат вычислений:

Создадим новый столбец, в который перезапишем оценки при условии, что оценка 2 интерпретируется как 0 с использованием формулы:

Результат вычислений:

Определим средний балл по формуле:

=СРЗНАЧ(D3:D14)

Результат:

Теперь получим средний балл успеваемости, для студентов, которые допущены к следующим экзаменам. Для этого воспользуемся еще одной логической функцией СРЗНАЧЕСЛИ:

Как получить значение по модулю числа без использования функции ABS

Пример 3. Реализовать алгоритм определения значения модуля числа (абсолютную величину), то есть альтернативный вариант для функции ABS.

Таблица данных:

Для решения используем формулу массива:

=ЕСЛИ(НЕ(A3:A10<0);A3:A10;A3:A10*(-1))

Описание аргументов:

  • НЕ(A3:A10<0) – проверка условия «принадлежит ли число к диапазону положительных значений или является 0 (нулем)?». Без использования функции не потребовалась бы более длинный вариант записи ИЛИ(A3:A10=0;A3:A10>0).
  • A3:A10 – возвращаемое число (соответствующий элемент из диапазона), если условие выполняется;
  • A3:A10*(-1) – возвращаемое число, если условие не выполняется (то есть, исходное значение принадлежит к диапазону отрицательных чисел, для получения модуля производится умножение на -1).

Результат:

Примечание: как правило, логические значения и сами функции (ИСТИНА(), ЛОЖЬ()) в выражениях явно не указываются, как это сделано в примерах 1 и 2. Например, во избежание промежуточных расчетов в Примере 2 можно было использовать формулу =ЕСЛИ(B3=2;0;B3), а так же =B3<>2.

При этом Excel автоматически определяет результат вычислений выражения B3<>2 или B3=2;0;B3 в аргументах функции ЕСЛИ (логическое сравнение) и на его основании выполняет соответствующее действие, предписанное вторым или третьим аргументами функции ЕСЛИ.

Основные операторы

Существует несколько операторов логических функций. Среди основных следует выделить такие:

  • ИСТИНА;
  • ЛОЖЬ;
  • ЕСЛИ;
  • ЕСЛИОШИБКА;
  • ИЛИ;
  • НЕ;
  • ЕОШИБКА;
  • ЕПУСТО.

Существуют и менее распространенные логические функции.

У каждого из вышеуказанных операторов, кроме первых двух, имеются аргументы. Аргументами могут выступать, как конкретные числа или текст, так и ссылки, указывающие адрес ячеек с данными.

Функции ЕОШИБКА и ЕПУСТО

Функция ЕОШИБКА проверяет, не содержит ли определенная ячейка или диапазон ячеек ошибочные значения. Под ошибочными значениями понимаются следующие:

  • #Н/Д;
  • #ЗНАЧ;
  • #ЧИСЛО!;
  • #ДЕЛ/0!;
  • #ССЫЛКА!;
  • #ИМЯ?;
  • #ПУСТО!

В зависимости от того ошибочный аргумент или нет, оператор сообщает значение ИСТИНА или ЛОЖЬ. Синтаксис данной функции следующий: = ЕОШИБКА(значение) . В роли аргумента выступает исключительно ссылка на ячейку или на массив ячеек.

Оператор ЕПУСТО делает проверку ячейки на то, пустая ли она или содержит значения. Если ячейка пустая, функция сообщает значение ИСТИНА, если ячейка содержит данные – ЛОЖЬ. Синтаксис этого оператора имеет такой вид: =ЕПУСТО(значение) . Так же, как и в предыдущем случае, аргументом выступает ссылка на ячейку или массив.

Пример применения функций

Теперь давайте рассмотрим применение некоторых из вышеперечисленных функций на конкретном примере.

Имеем список работников предприятия с положенными им заработными платами. Но, кроме того, всем работникам положена премия. Обычная премия составляет 700 рублей. Но пенсионерам и женщинам положена повышенная премия в размере 1000 рублей. Исключение составляют работники, по различным причинам проработавшие в данном месяце менее 18 дней. Им в любом случае положена только обычная премия в размере 700 рублей.

Попробуем составить формулу. Итак, у нас существует два условия, при исполнении которых положена премия в 1000 рублей – это достижение пенсионного возраста или принадлежность работника к женскому полу. При этом, к пенсионерам отнесем всех тех, кто родился ранее 1957 года. В нашем случае для первой строчки таблицы формула примет такой вид: =ЕСЛИ(ИЛИ(C4<1957;D4="жен.");"1000";"700") . Но, не забываем, что обязательным условием получения повышенной премии является отработка 18 дней и более. Чтобы внедрить данное условие в нашу формулу, применим функцию НЕ: =ЕСЛИ(ИЛИ(C4<1957;D4="жен.")*(НЕ(E4<18));"1000";"700") .

Для того, чтобы скопировать данную функцию в ячейки столбца таблицы, где указана величина премии, становимся курсором в нижний правый угол ячейки, в которой уже имеется формула. Появляется маркер заполнения. Просто перетягиваем его вниз до конца таблицы.

Таким образом, мы получили таблицу с информацией о величине премии для каждого работника предприятия в отдельности.

Как видим, логические функции являются очень удобным инструментом для проведения расчетов в программе Microsoft Excel. Используя сложные функции, можно задавать несколько условий одновременно и получать выводимый результат в зависимости от того, выполнены эти условия или нет. Применение подобных формул способно автоматизировать целый ряд действий, что способствует экономии времени пользователя.

Основные логические функции, используемые в Эксель

Перечень наиболее часто используемых логических операторов можно ограничить следующим набором:

  • ИСТИНА;
  • ЛОЖЬ;
  • ЕСЛИ;
  • ЕСЛИОШИБКА;
  • ИЛИ;
  • НЕ;
  • ЕОШИБКА;
  • ЕПУСТО.

В большинстве случаев их достаточно для построения сложных логических конструкций и задания условий.

Для каждого из указанных выше операторов существуют аргументы (за исключением функций ИСТИНА и ЛОЖЬ) – это могут быть как цифровые или текстовые значения, так и ссылки на данные, содержащиеся в других ячейках.

Практический пример использования логических функций

В примере ниже попробуем частично использовать описанные выше функции для решения задачи, приближенной к реальной ситуации с расчетом премии, зависящей от определенных условий.

В качестве исходных данных – таблица со сведениями о работниках, в которой указан их пол и возраст.

Нам необходимо произвести расчет премии. Ключевые условия, от которых зависит размер премии:

  • величина обычной премии, которую получат все сотрудники без исключения – 3 000 руб.;
  • сотрудницам женского пола положена повышенная премия – 7 000 руб.;
  • молодым сотрудникам (младше 1984 г. рождения) положена повышенная премия – 7 000 руб.;

Выполним необходимые расчеты, используя логические функции.

  1. Встаем в первую ячейку столбца, в которой хотим посчитать размеры премий и щелкаем кнопку “Вставить функцию” (слева от сроки формул).
  2. В открывшемся Мастере функций выбираем категорию “Логические”, затем в предложенном перечне операторов кликаем по строке “ЕСЛИ” и жмем OK.
  3. Теперь нам нужно задать аргументы функции. Так как у нас не одно, а два условия получения повышенной премии, причем нужно, чтобы выполнялось хотя бы одно из них, чтобы задать логическое выражение, воспользуемся функцией ИЛИ. Находясь в поле для ввода значения аргумента “Лог_выражение” кликаем в основной рабочей области книги на небольшую стрелку вниз, расположенную в левой верхней части окна программы, где обычно отображается адрес ячейки. В открывшемся списке функций выбираем оператор ИЛИ, если он представлен в перечне (или можно кликнуть на пункт “Другие функции” и выбрать его в новом окне Мастера функций, как мы изначально сделали для выбора оператора ЕСЛИ).
  4. Мы переключимся в окно аргументов функци ИЛИ. Здесь задаем наши условия получения премии в 7000 руб.:
    • год рождения позже 1984 года;
    • пол – женский;
  5. Теперь обращаем внимание на строку формул. Кликаем в ней на название первоначального оператора ЕСЛИ, чтобы переключиться в аргументы этой функции.
  6. Заполняем аргументы функции и щелкаем OK:
    • в значении “Истина” пишем цифру 7000;
    • в значении “Ложь” указываем цифру 3000;
  7. Результат работы логических операторов отобразится в первой ячейке столбца, которую мы выбрали. Как мы можем видеть, окончательный вид формулы выглядит следующим образом:
    =ЕСЛИ(ИЛИ(C2>1984;D2="жен.");7000;3000).
    Кстати, вместо использования Мастера функций можно было вручную составить и прописать данную формулу в требуемой ячейке.
  8. Чтобы рассчитать премию для всех сотрудников, воспользуемся Маркером заполнения. Наведем курсор на правый нижний угол ячейки с формулой. После того, как курсор примет форму черного крестика (это и есть Маркер заполнения), зажимаем левую кнопку мыши и протягиваем выделение вниз, до последней ячейки столбца.
  9. Все готово. Благодаря логическим операторам мы получили заполненные данные для столбца с премиями.

Логическая функция ИСКЛИЛИ в Excel

В Excel 2013 Microsoft представила функцию ИСКЛИЛИ, которая является логической функцией исключающего ИЛИ. Для тех, кто не знаком с понятием «Исключающего ИЛИ», сначала может быть немного сложно понять суть логической функции, но, надеюсь, приведенное ниже объяснение иллюстрируемое примерами формул поможет прояснить суть.

Синтаксис логической функции ИСКЛИЛИ идентичен синтаксису ИЛИ:

=ИСКЛИЛИ(логическое_значение1; [логическое_значение2];…)

В простейшей версии формулы ИСКЛИЛИ, содержащей только 2 логических оператора, логическая функция Excel ИСКЛИЛИ вернет ИСТИНУ, если любой из аргументов имеет значение ИСТИНА. Если оба аргумента ИСТИНА, либо оба ЛОЖЬ, ИСКЛИЛИ возвращает ЛОЖЬ. Рассмотрим примеры формул:

Формула

Результат

Описание

=ИСКЛИЛИ(1>0; 2<1)

ИСТИНА

Логическая функция возвращает ИСТИНА, потому что первый аргумент ИСТИНА, а второй аргумент ЛОЖЬ.

=ИСКЛИЛИ(1<0; 2<1)

ЛОЖЬ

Логическая функция возвращает ЛОЖЬ, потому что оба аргумента ЛОЖЬ.

=ИСКЛИЛИ(1>0; 2>1)

ЛОЖЬ

Логическая функция возвращает ЛОЖЬ, потому что оба аргумента ИСТИНА.

Когда добавляется больше логических операторов, функция ИСКЛИЛИ в Excel работает следующим образом:

  • ИСТИНА, если нечетное число аргументов оценивается как ИСТИНА;
  • ЛОЖЬ, если общее число ИСТИННЫХ утверждений четно, или если все операторы ЛОЖЬ.

Представленное ниже изображение наглядно это иллюстрирует:

Заключение

Логические операторы используются практически во всех сложных формулах, в которых значение в ячейке зависит от соблюдения одного или нескольких условий и позволяют строить гибкие конструкции, объединяя простые функции и расчеты в одной ячейке. Это дает возможность значительно сократить время на обработку данных и повысить эффективность работы, так как снимает большое количество промежуточных шагов в расчетах и вычислениях.

Источники


  • https://officelegko.com/2019/09/14/logicheskie-funkczii-v-eksele/
  • https://mister-office.ru/funktsii-excel/function-if-excel-primery.html
  • https://excelhack.ru/funkciya-false-lozh-v-excel/
  • https://exceltable.com/funkcii-excel/primery-funkciy-istina-lozh-ne
  • https://lumpics.ru/logical-functions-in-excel/
  • https://MicroExcel.ru/logicheskie-funkczii/
  • https://naprimerax.org/posts/76/logicheskie-funktcii-v-excel

Рейтинг
( Пока оценок нет )
Понравилась статья? Поделиться с друзьями:
Все об Экселе: формулы, полезные советы и решения