Примеры функций СЧЁТЗ И СЧИТАТЬПУСТОТЫ в Excel для пустых ячеек

Содержание
  1. Примеры использования функций СЧЁТЗ и СЧИТАТЬПУСТОТЫ в Excel
  2. Проверка заполнения данными таблицы с помощью функции СЧЁТЗ в Excel
  3. Синтаксис функции СЧЕТЗ
  4. Подготовка исходной таблицы
  5. Синтаксис функции БСЧЁТ()
  6. Задача 1 (с одним критерием)
  7. Задача 2 (Два критерия (разные столбцы), условие И)
  8. Задача 3 (Два критерия (один столбец), условие И)
  9. Задача 4 (Два критерия (один столбец), условие ИЛИ)
  10. Как работает стандартное отклонение в Excel?
  11. Эксперимент
  12. Функция СЧЁТ, СЧЁТЗ и СЧИТАТЬПУСТОТЫ для подсчета ячеек в Excel
  13. I . Для определения количества ячеек, содержащих числовые значения, можно использовать функцию Счет.
  14. Примеры использования функции Счет.
  15. Функция Счётз
  16. III . Если требуется посчитать количество пустых ячеек в Excel, используйте функцию Считатьпустоты .
  17. Для подсчета текста.
  18. Подсчет ячеек, начинающихся или заканчивающихся определенными символами
  19. Подсчет чисел по условию.
  20. Примеры с датами.
  21. Функция СЧЕТ (COUNT) в Excel
  22. Подсчет количества заполненных ячеек с помощью функции СЧЁТЗ
  23. Посчитать заполненные ячейки функцией СЧЁТЕСЛИ
  24. Синтаксис функции СЧЁТЗ
  25. Простой пример использования функции СЧЁТЗ
  26. Пример использования функций СЧЁТЗ и СЧИТАТЬПУСТОТЫ в Excel
  27. Пример использования функции СЧЁТЕСЛИ с условием
  28. Работа с оператором СЧЁТ
  29. Мастер функций

Примеры использования функций СЧЁТЗ и СЧИТАТЬПУСТОТЫ в Excel

Пример 1. В магазине ведется учет проданных товаров за день и соответствующие данные записываются в таблицу Excel. Некоторые товары проданы не были, поэтому ячейки в столбце «Количество» заполнены не были. Определить количество товаров, которые не пользовались спросом на протяжении дня.

Таблица данных:

Формула для расчета:

=СЧИТАТЬПУСТОТЫ(B3:B10)

Описание аргумента:

  • B3:B10 – диапазон, в котором подсчитывается число пустых ячеек.

Результат вычислений:

В и тоге получилось 3 вида непроданных товаров в розничной точке на протяжении целого торгового дня.

Проверка заполнения данными таблицы с помощью функции СЧЁТЗ в Excel

Пример 2. Для решения спорных ситуаций в случае ДТП в Excel была создана форма для расчета тормозного пути автомобиля. Таблица содержит 4 поля данных, являющихся обязательными для заполнения. Реализовать алгоритм выведения ошибки «Указаны не все данные» в случае, если для расчета не хватает данных.

Исходная таблица:

Функция, которая будет выводить ошибку, если не все данные введены:

=ЕСЛИ(СЧЁТЗ(A2:A5)<>СЧЁТЗ(B2:B5);”Указаны не все данные”;B4*0,28*B5+(СТЕПЕНЬ(B4*0,28;2)/(2*B3*B2)))

В столбце A:A содержатся пояснения к данным, находящимся в соседнем столбце. Если число заполненных ячеек в A2:A5 и B2:B5 совпадают, будет выполнен расчет по формуле B4*0,28*B5+(СТЕПЕНЬ(B4*0,28;2)/(2*B3*B2)), иначе будет выведена информация об ошибке. В данном случае все поля указаны и заполнены. Результат:

Если, например, время реакции не указано, будет выведен следующий результат:

Синтаксис функции СЧЕТЗ

СЧЕТЗ(значение1; [значение2]; …)

COUNTA(value1, [value2], …)

В качестве аргументов функции СЧЕТЗ могут выступать любые значения, ссылки на ячейки и диапазоны, массивы данных, а также формулы и функции.

Значение1 (value1) – обязательный аргумент функции СЧЕТЗ, все остальные аргументы являются необязательными и могут быть опущены.

Начиная с версии Excel 2007, Вы можете использовать до 255 аргументов, каждый из которых способен содержать огромное количество данных. В более ранних версиях Excel (например, Excel 2003 года), функция СЧЕТЗ обрабатывала лишь 30 аргументов.

Подготовка исходной таблицы

Для использования этой функции требуется чтобы:

  • исходная таблица имела заголовки столбцов;
  • критерии были оформлены виде небольшой отдельной таблицы с заголовками;
  • заголовки таблицы критериев совпадали с заголовками исходной таблицы (если критерий не задается формулой).

Синтаксис функции БСЧЁТ()

БСЧЁТ(база_данных; поле; критерий)

Аргумент База_данных представляет собой таблицу (см. строки 8-13 на рисунке выше), по одному из столбцов которой производится подсчет значений. Верхняя строка таблицы должна содержать заголовки столбцов.

Поле — это название заголовка столбца, по которому производится подсчет. Аргумент Поле можно заполнить введя:

  • текст с заголовком столбца в двойных кавычках, например “Продавец” или “Продажи”,
  • число (без кавычек), задающее положение столбца в таблице (указанной в аргументе база_данных ): 1 — для первого столбца, 2 — для второго и т.д.
  • ссылку на заголовок столбца.

Подразумевается, что этот столбец содержит числа, инача функция вернет 0.

Примечание : Если значения в этом столбце содержат числа, сохраненные в текстовом формате , то нужно использовать функцию БСЧЁТА() .

Примечание : В теории баз данных строки таблицы называются записями, а столбцы — полями (отсюда и необычное название аргумента).

Критерий — интервал ячеек, который содержит задаваемые условия (т.е. ссылка на таблицу критериев). См. строки 2-4 на рисунке выше. Этот интервал ячеек аналогичен таблице для Расширенного фильтра и функции БДСУММ() и, конечно, БСЧЁТА() .

Задача 1 (с одним критерием)

Подсчитаем количество продаж на сумму >3000. Т.е. подсчет будем вести по столбцу Продажи .

Алгоритм следующий:

  • Создадим табличку критериев (желательно над исходной таблицей, чтобы она не мешала добавлению новых данных в таблицу), например в диапазоне A2:A3 (см. рисунок выше). Табличка должна состоять из заголовка (совпадает с названием заголовка столбца исходной таблицы, к которому применяется критерий) и собственно критерия (условия отбора);
  • Условия отбора могут быть записаны в текстовом формате. В нашем случае, просто >3000
  • Теперь можно записать саму формулу =БСЧЁТ(B8:B13;B8;A2:A3) В B8:B13 находится База_данных (исходная таблица). Столбец А (Продавец) можно в данном случае не включать в базу_данных , т.к. по нему не производится подсчет и он не участвует в отборе. B8 – это ссылка на заголовок столбца по которому будет производиться подсчет ( Продажи ), в нем должны быть числовые значения. A2:A3 – ссылка на табличку критериев.

Альтернативное решение – простая формула = СЧЁТЕСЛИ(B9:B13;A3) .

Вывод : для простых однокритериальных задач огород с функцией =БСЧЁТ() городить не стоит.

Задача 2 (Два критерия (разные столбцы), условие И)

Подсчитаем Число продаж Белова, которые меньше 3000.

В этом случае, критерии отбора должны размещаться под заголовками, названия которых совпадают с заголовками столбцов исходной таблицы, по которым будет производиться подсчет (столбцы Продавец и Продажи ). Критерии должны располагаться в одной строке (см. диапазон на рисунке выше A2:B3 ).

Записать саму формулу можно так =БСЧЁТ(A8:B13;B8;A2:B3)

Альтернативное решение – простая формула = СЧЁТЕСЛИМН(A9:A13;”Белов”;B9:B13;A3) .

Задача 3 (Два критерия (один столбец), условие И)

Подсчитаем число продаж в интервале >3000 и

В этом случае, критерии отбора должны размещаться под заголовками, названия которых совпадают с заголовками столбцов исходной таблицы, по которым будет производиться поиск (столбец Продажи ). Критерии должны располагаться в одной строке.

Записать саму формулу можно так =БСЧЁТ(B8:B13;B8;D2:E3)

Альтернативное решение простая формула =СЧЁТЕСЛИМН(B9:B13;”>3000″;B9:B13;”

Задача 4 (Два критерия (один столбец), условие ИЛИ)

Подсчитаем число продаж 6000.

В этом случае, критерии отбора должны размещаться под одним заголовком (столбец Продажи ). Критерии должны располагаться в разных строках.

Записать саму формулу можно так =БСЧЁТ(B8:B13;B8;A2:A4)

Альтернативное решение формула =СЧЁТЕСЛИ(B9:B13;”6000″)

Как работает стандартное отклонение в Excel?

В жизни функции стандартных отклонений используются для определения стабильности продаваемой продукции, создания цены, корректировки или формирования ассортимента, ну и других не менее полезных анализов ваших продаж.

В программе Excel используются несколько вариантов функции отклонения:

  • Функция СТАНДОТКЛОНА – вычисляется отклонение по выборке текстовых и логических значений. При этом ложные логические и текстовые значения формула приравнивает к 0, а 1 будут равняться только истинные логические значения;
  • Функция СТАНДОТКЛОН.В – производит оценку стандартного отклонения по выборке, при этом текстовые и логические значения игнорирует;
  • Функция СТАНДОТКЛОН.Г – делает оценку отклонения по некой генеральной совокупности и как в предыдущей функции игнорируются текстовые и логические значения;
  • Функция СТАНДОТКЛОНПА – также вычисляет по генеральной совокупности стандартное отклонение, но с учетом текстовых и логических значений. Равняться 1 будут только истинные логические значения, а ложные логические и текстовые значения будут приравнены к 0.
 

Эксперимент

Для иллюстрации приведем пример того как рассматривают ячейку с Пустым текстом Условное форматирование и функция ЕПУСТО() (см. Файл примера ).

Рассмотрим диапазон A1:D4 , содержащий числа, текст, пустые ячейки и Пустой текст “” (наиболее общий случай).

Ячейка С4 содержит значение Пустой текст (введено как результат вычисления формулы =ЕСЛИ(1>2;1;””) ) и выделена жирной границей. Условное форматирование с правилом « Форматировать только те ячейки, которые пустые » выделит действительно пустые ячейки и ячейку со значением Пустой текст !

Функция ЕПУСТО() не разделяет такого подхода и говорит, что в С4 , что-то есть (формула =ЕПУСТО(C4) введенная в ячейку С5 возвращает ЛОЖЬ).

Функция СЧИТАТЬПУСТОТЫ() также как и Условное форматирование , учитывает при подсчете ячейки со значением Пустой текст вместе с пустыми ячейками.

Чтобы не запутаться с подсчетом пустых ячеек в диапазоне С2:С11 при наличии значений Пустой текст, приведем обобщающую таблицу:

Формула или средство EXCEL

Различает ли пустую ячейку и ячейку со значением Пустой текст ?

Комментарий

Условное форматирование

нет

пустая ячейка и ячейка со значением Пустой текст считаются тождественными

= СЧИТАТЬПУСТОТЫ(С2:С11)

нет

подсчитает все пустые ячейки и ячейки, содержащие Пустой текст

= СУММПРОИЗВ( –(C2:C11=””))

нет

–//–

= СЧЁТЕСЛИ(C2:C11;””)

нет

–//–

= СУММПРОИЗВ(–ЕПУСТО(C2:C11))

да

подсчет только пустых ячеек

Функция СЧЁТ, СЧЁТЗ и СЧИТАТЬПУСТОТЫ для подсчета ячеек в Excel

Ниже на рисунке представлены разные методы подсчета значений из определенного диапазона данных таблицы:

В строке 9 (диапазон B9:E9) функция СЧЁТ подсчитывает числовые значения только тех учеников, которые сдали экзамен. СЧЁТЗ в столбце G (диапазон G2:G6) считает числа всех экзаменов, к которым приступили ученики. В столбце H (диапазон H2:H6) функция СЧИТАТЬПУСТОТЫ ведет счет только для экзаменов, к которым ученики еще не подошли.

I . Для определения количества ячеек, содержащих числовые значения, можно использовать функцию Счет.

Счет(значение1; [значение2]; …)

Значение1 – обязательный аргумент, все остальные аргументы являются необязательными и могут быть опущены.

В качестве аргументов функции Счет могут выступать любые значения, ссылки на ячейки и диапазоны, массивы данных, а также формулы и функции.

В более ранних версиях Excel (например, Excel 2003 года), функция Счет обрабатывала 30 аргументов. Начиная с версии Excel 2007, можно использовать до 255 аргументов.

Числа, даты и время учитываются функцией Счет как числовые.

Ссылки на пустые ячейки, ошибки, текстовые или логические значения игнорируются.

Если число сохранено как текст, оно не будет посчитано!

Примеры использования функции Счет.

  1. Подсчет количества ячеек в диапазоне, который полностью состоит из чисел:

  1. В диапазоне есть пустые ячейки, ячейки содержащие числа и текст.

Функция Счет игнорирует пустые ячейки, и ячейки содержащие текст.

  1. Ячейки, содержащие значения даты и времени функция Счет учитывает:

  1. Функция Счет может подсчитывать количество ячеек сразу в нескольких несмежных диапазонах:

Функция Счётз

Счётз(значение1; [значение2]; …)
В качестве аргументов функции Счётз могут выступать любые значения, ссылки на ячейки и диапазоны, массивы данных, а также формулы и функции.

Функция Счётз учитывает данные любого типа, включая ошибки.

Ячейки, содержащие пустые строки =«« (две кавычки, между которыми ничего нет), засчитываются как Непустые.

Например, в ячейке С2 – пустая строка, т.е. С2=««. Функция Счётз учтет эту ячейку при подсчете.

III . Если требуется посчитать количество пустых ячеек в Excel, используйте функцию Считатьпустоты .

Считатьпустоты (диапазон)

Диапазон ячеек для проверки – единственный аргумент, который является обязательным.

Ячейки, содержащие пустые строки (=««), засчитываются как ПУСТЫЕ.

Например, в ячейке С2 – пустая строка, т.е. С2=««. Функция Считатьпустоты учтет эту ячейку при подсчете.

Для подсчета текста.

Давайте разбираться, как это работает. На рисунке ниже вы видите список заказов, выполненных менеджерами. Выражение =СЧЕТЕСЛИ(В2:В22,”Никитенко”) подсчитывает, сколько раз этот работник присутствует в списке:

Замечание. Критерий не чувствителен к регистру букв, поэтому можно вводить как прописные, так и строчные буквы.

Если ваши данные содержат несколько вариантов слов, которые вы хотите сосчитать, то вы можете использовать подстановочные знаки для подсчета всех ячеек, содержащих определенное слово, фразу или буквы, как часть их содержимого.

К примеру, в нашей таблице есть несколько заказчиков «Корона» из разных городов. Нам необходимо подсчитать общее количество заказов «Корона» независимо от города.

=СЧЁТЕСЛИ(A2:A22;”*Коро*”)

Мы подсчитали количество заказов, где в наименовании заказчика встречается «коро» в любом регистре. Звездочка (*) используется для поиска ячеек с любой последовательностью начальных и конечных символов, как показано в приведенном выше примере. Если вам нужно заменить какой-либо один символ, введите вместо него знак вопроса (?).

Кроме того, указывать условие прямо в формуле не совсем рационально, так как при необходимости подсчитать какие-то другие значения вам придется корректировать её. А это не слишком удобно.

Рекомендуется условие записывать в какую-либо ячейку и затем ссылаться на нее. Так мы сделали в H9. Также можно употребить подстановочные знаки со ссылками с помощью оператора конкатенации (&). Например, вместо того, чтобы указывать «* Коро *» непосредственно в формуле, вы можете записать его куда-нибудь, и использовать следующую конструкцию для подсчета ячеек, содержащих «Коро»:

=СЧЁТЕСЛИ(A2:A22;”*”&H8&”*”)

Подсчет ячеек, начинающихся или заканчивающихся определенными символами

Вы можете употребить подстановочный знак звездочку (*) или знак вопроса (?) в зависимости от того, какого именно результата вы хотите достичь.

Если вы хотите узнать количество ячеек, которые начинаются или заканчиваются определенным текстом, независимо от того, сколько имеется других символов, используйте:

=СЧЁТЕСЛИ(A2:A22;”К*”) – считать значения, которые начинаются с « К» .

=СЧЁТЕСЛИ(A2:A22;”*р”) – считать заканчивающиеся буквой «р».

Если вы ищете количество ячеек, которые начинаются или заканчиваются определенными буквами и содержат точное количество символов, то поставьте вопросительный знак (?):

=СЧЁТЕСЛИ(С2:С22;”????д”) – находит количество буквой «д» в конце и текст в которых состоит из 5 букв, включая пробелы.

= СЧЁТЕСЛИ(С2:С22,”??”) – считает количество состоящих из 2 символов, включая пробелы.

Примечание. Чтобы узнать количество клеток, содержащих в тексте знак вопроса или звездочку, введите тильду (~) перед символом ? или *.

Например, = СЧЁТЕСЛИ(С2:С22,”*~?*”) будут подсчитаны все позиции, содержащие знак вопроса в диапазоне С2:С22.

Подсчет чисел по условию.

В отношении чисел редко случается, что нужно подсчитать количество их, равных какому-то определённому числу. Тем не менее, укажем, что записать нужно примерно следующее:

= СЧЁТЕСЛИ(D2:D22,10000)

Гораздо чаще нужно высчитать количество значений, больших либо меньших определенной величины.

Чтобы подсчитать значения, которые больше, меньше или равны указанному вами числу, вы просто добавляете соответствующий критерий, как показано в таблице ниже.

Обратите внимание, что математический оператор вместе с числом всегда заключен в кавычки .

критерии

Описание

Если больше, чем

=СЧЕТЕСЛИ(А2:А10;”>5″)

Подсчитайте, где значение больше 5.

Если меньше чем

=СЧЕТЕСЛИ(А2:А10;”>5″)

Подсчет со числами менее 5.

Если равно

=СЧЕТЕСЛИ(А2:А10;”=5″)

Определите, сколько раз значение равно 5.

Если не равно

=СЧЕТЕСЛИ(А2:А10;”<>5″)

Подсчитайте, сколько раз не равно 5.

Если больше или равно

=СЧЕТЕСЛИ(А2:А10;”>=5″)

Подсчет, когда больше или равно 5.

Если меньше или равно

=СЧЕТЕСЛИ(А2:А10;”<=5″)

Подсчет, где меньше или равно 5.

В нашем примере

=СЧЁТЕСЛИ(D2:D22;”>10000″)

Считаем количество крупных заказов на сумму более 10 000. Обратите внимание, что условие подсчета мы записываем здесь в виде текстовой строки и поэтому заключаем его в двойные кавычки.

Вы также можете использовать все вышеприведенные варианты для подсчета ячеек на основе значения другой ячейки. Вам просто нужно заменить число ссылкой.

Замечание. В случае использования ссылки, вы должны заключить математический оператор в кавычки и добавить амперсанд (&) перед ним. Например, чтобы подсчитать числа в диапазоне D2: D9, превышающие D3, используйте =СЧЕТЕСЛИ(D2:D9,”>”&D3)

Если вы хотите сосчитать записи, которые содержат математический оператор, как часть их содержимого, то есть символ «>», «<» или «=», то употребите в условиях подстановочный знак с оператором. Такие критерии будут рассматриваться как текстовая строка, а не числовое выражение.

Например, =СЧЕТЕСЛИ(D2:D9,”*>5*”) будет подсчитывать все позиции в диапазоне D2: D9 с таким содержимым, как «Доставка >5 дней» или «>5 единиц в наличии».

Примеры с датами.

Если вы хотите сосчитать клетки с датами, которые больше, меньше или равны указанной вами дате, вы можете воспользоваться уже знакомым способом, используя формулы, аналогичные тем, которые мы обсуждали чуть выше. Все вышеприведенное работает как для дат, так и для чисел.

Позвольте привести несколько примеров:

критерии

Описание

Даты, равные указанной дате.

=СЧЕТЕСЛИ(E2:E22;”01.02.2019″)

Подсчитывает количество ячеек в диапазоне E2:E22 с датой 1 июня 2014 года.

Даты больше или равные другой дате.

=СЧЕТЕСЛИ(E2:E22,”>=01.02.2019″)

Сосчитайте количество ячеек в диапазоне E2:E22 с датой, большей или равной 01.06.2014.

Даты, которые больше или равны дате в другой ячейке, минус X дней.

=СЧЕТЕСЛИ(E2:E22,”>=”&H2-7)

Определите количество ячеек в диапазоне E2:E22 с датой, большей или равной дате в H2, минус 7 дней.

Помимо этих стандартных способов, вы можете употребить функцию СЧЕТЕСЛИ в сочетании с функциями даты и времени, например, СЕГОДНЯ(), для подсчета ячеек на основе текущей даты.

критерии

Равные текущей дате.

=СЧЕТЕСЛИ(E2:E22;СЕГОДНЯ())

До текущей даты, то есть меньше, чем сегодня.

=СЧЕТЕСЛИ(E2:E22;”<“&СЕГОДНЯ())

После текущей даты, т.е. больше, чем сегодня.

=СЧЕТЕСЛИ(E2:E22;”>”& ЕГОДНЯ ())

Даты, которые должны наступить через неделю.

= СЧЕТЕСЛИ(E2:E22,”=”&СЕГОДНЯ()+7)

В определенном диапазоне времени.

=СЧЁТЕСЛИ(E2:E22;”>=”&СЕГОДНЯ()+30)-СЧЁТЕСЛИ(E2:E22;”>”&СЕГОДНЯ())

Функция СЧЕТ (COUNT) в Excel

​ реализации проекта за​​ этих ячейках отображаются​С помощью различных комбинаций​6​ смежными, если они​), например “25” или​ задать условия в​ итогов в отчете​Число​ справочного материала.​ использовании предыдущего способа.​​ Excel​​ подсчета только ячеек​

Подсчет количества заполненных ячеек с помощью функции СЧЁТЗ

Самый простой путь – использовать функцию СЧЁТЗ, которая подсчитывает клетки, содержащие значения:

=СЧЁТЗ(массив)

Посчитать заполненные ячейки функцией СЧЁТЕСЛИ

Второй подход – использовать функцию СЧЁТЕСЛИ, которая более широко применяется и может легче запомниться:

=СЧЁТЕСЛИ(массив

Первый и второй способы дали одинаковые результаты – 21 значение в массиве. Однако, если пересчитать вручную – их окажется только 20. Это и есть та особенность, о которой я говорил выше. В ячейке E5 содержится формула, которая результатом возвращает пустую строку. Запомните, функции СЧЁТЗ и СЧЁТЕСЛИ считают подобные ячейки непустыми.

Если для Вас это имеет значение, и пустые ячейки с формулами считать не нужно, используйте описанный дальше подход.

Синтаксис функции СЧЁТЗ

Поскольку функция СЧЁТЗ подсчитывает количество любых непустых ячеек, то её параметрами являются один или более диапазонов ячеек. Других типов параметров формула не имеет

Обобщённый синтаксис функции СЧЁТЗ:
СЧЁТЗ(значение1; [значение2]; …)

Всего функция СЧЁТЗ может принимать до 255-ти аргументов. Минимальное количество аргументов — один (иначе не будет входных данных для обработки).

Аргументом может быть диапазон ячеек или отдельная ячейка. Также можно использовать имена переменных при условии что им соответствуют диапазоны или отдельные ячейки.

Функция СЧЁТЗ подсчитывает ячейки, содержащие данные любого типа, включая значения ошибок и пустой текст (“”). Например, если в диапазоне есть формула, которая возвращает пустую строку, функция СЧЁТЗ учитывает это значение. Функция СЧЁТЗ не учитывает пустые ячейки.

Также стоит учитывать следующее:

  • Если подсчитывать логические значения, элементы текста и значения ошибок не требуется (иными словами, если необходимо подсчитать только количество ячеек с числами), используйте функцию СЧЁТ.
  • Если требуется подсчитать только те ячейки, которые соответствуют определенным критериям, используйте функцию СЧЁТЕСЛИ или СЧЁТЕСЛИМН.

Других особенностей у данной формулы нет, поэтому использовать её предельно просто.

Простой пример использования функции СЧЁТЗ

В принципе, примера как такового здесь не требуется, учитывая простоту рассмотренной формулы. Тем не менее после статьи Вы можете скачать файл Excel, в котором есть пример использования функции СЧЁТЗ.

Откройте скачанный файл и посмотрите в ячейку C16, в которой содержится формула. В данном случае указан только один аргумент в виде диапазона ячеек, охватывающего обе таблицы на листе (не считая результатов, выделенных синим фоном).

Пример использования функций СЧЁТЗ и СЧИТАТЬПУСТОТЫ в Excel

Вы сможете быстро определить количество заполненных или пустых клеток в заданной области таблицы. Для выполнения этих операций используются функции с именами «СЧЁТЗ» и «СЧИТАТЬПУСТОТЫ». Для наглядности этой возможности необходимо рассмотреть пример.

Пример 2. В таблицу введены разные значения. Среди них нет никаких закономерностей. Есть пустые и заполненные ячейки.

В любом месте таблицы можно ввести функцию. Для определения заполненных ячеек в диапазоне А1:С5 нужно прописать такую формулу:

Введение её через Enter даст результат 8. Именно столько заполненных ячеек есть в обозначенной области.

Чтобы узнать количество пустых клеток, нужно ввести функцию СЧИТАТЬПУСТОТЫ:

Введение формулы покажет результат 7. Это количество пустых ячеек в таблице.

Пример использования функции СЧЁТЕСЛИ с условием

Очень часто используется такая разновидность функции «СЧЁТ». С помощью заданной формулы можно узнать количество ячеек с заданными параметрами. Функция имеет имя «СЧЁТЕСЛИ». В ней могут учитываться такие аргументы.

  1. Диапазон. Табличная область, в которой будут искаться определённые элементы.
  2. Критерий. Признак, который разыскивается в заданной области.

Синтаксис выглядит так:

Функция может показать количество ячеек с заданным текстом. Для этого аргумент заключается в кавычки. При этом не учитывается текстовый регистр. В синтаксисе формулы не может быть пробелов.

Оба аргумента являются обязательными для указания. Для наглядности стоит рассмотреть следующий пример.

Пример 3. Есть ведомость с фамилиями студентов и оценками за экзамен. В таблице 2 столбца и 10 ячеек. Нужно определить, какое количество студентов получили отличную оценку 5 (по пятибалльной системе оценивания), а какое 4, потом 3 и 2.

Для определения количества отличников нужно провести анализ содержимого ячеек второго столбика. В отдельной табличке нужно использовать простую функцию подсчета количества числовых значений с условием СЧЁТЕСЛИ:

После нажатия на клавиатуре Enter будет получен результат:

    Работа с оператором СЧЁТ

    Функция СЧЁТ относится к большой группе статистических операторов, в которую входит около сотни наименований. Очень близка к ней по своим задачам функция СЧЁТЗ. Но, в отличие от предмета нашего обсуждения, она учитывает ячейки, заполненные абсолютно любыми данными. Оператор СЧЁТ, о котором мы поведем подробный разговор, ведет подсчет только ячеек, заполненных данными в числовом формате.

    Какие же данные относятся к числовым? Сюда однозначно относятся собственно числа, а также формат даты и времени. Логические значения («ИСТИНА», «ЛОЖЬ» и т.д.) функция СЧЁТ учитывает только тогда, когда они являются именно её непосредственным аргументом. Если же они просто находятся в области листа, на которую ссылается аргумент, то в таком случае оператор их в расчет не берет. Аналогичная ситуация с текстовым представлением чисел, то есть, когда числа записаны в кавычки или окружены другими знаками. Тут тоже, если они являются непосредственным аргументом, то принимают участие в подсчете, а если просто на листе, то не принимают.

    А вот применительно к чистому тексту, в котором не присутствуют цифры, или к ошибочным выражениям («#ДЕЛ/0!», #ЗНАЧ! И т.д.) ситуация другая. Такие значения функция СЧЁТ не учитывает в любом виде.

    Кроме функций СЧЁТ и СЧЁТЗ, подсчетом количества заполненных ячеек занимается ещё операторы СЧЁТЕСЛИ и СЧЁТЕСЛИМН. С помощью данных формул можно производить подсчет с учётом дополнительных условий. Этой группе статистических операторов посвящена отдельная тема.

    Мастер функций

    Для неопытного пользователя легче всего производить подсчет ячеек, содержащих числа, используя формулу СЧЁТ при помощи Мастера функций.

    1. Кликаем по пустой ячейке на листе, в которую будет выводиться результат расчета. Жмем на кнопку «Вставить функцию».

      Есть и другой вариант запуска Мастера функций. Для этого после выделения ячейки нужно перейти во вкладку «Формулы». На ленте в блоке инструментов «Библиотека функций» жмем на кнопку «Вставить функцию».

      Существует ещё один вариант, наверное, самый простой, но вместе с тем требующий хорошей памяти. Выделяем ячейку на листе и жмем комбинацию клавиш на клавиатуре Shift+F3.

    2. Во всех трёх случаях запустится окно Мастера функций. Для перехода к окну аргументов в категории «Статистические» или «Полный алфавитный перечень» ищем элемент «СЧЁТ». Выделяем его и кликаем по кнопке «OK».

      Также окно аргументов можно запустить другим способом. Выделяем ячейку для вывода результата и переходим во вкладку «Формулы». На ленте в группе настроек «Библиотека функций» жмем по кнопке «Другие функции». Из появившегося списка наводим курсор на позицию «Статистические». В открывшемся меню выбираем пункт «СЧЁТ».

    3. Запускается окно аргументов. Единственным аргументом данной формулы может быть значение, представленное в виде ссылки или просто записанное в соответствующее поле. Правда, начиная с версии Excel 2007, таких значений может быть до 255 включительно. В более ранних версиях их было всего 30.

      Данные занести в поля можно, набрав с клавиатуры конкретные значения или координаты ячеек. Но при наборе координат намного легче просто установить курсор в поле и выделить соответствующую ячейку или диапазон на листе. Если диапазонов несколько, то адрес второго из них можно занести в поле «Значение2» и т.д. После того, как значения занесены, жмем на кнопку «OK».

    4. Результат подсчета ячеек, содержащих числовые значения в выделенном диапазоне, отобразится в первоначально указанной области на листе.

    Источники


    • https://exceltable.com/funkcii-excel/primery-funkciy-schetz-i-schitatpustoty
    • https://office-guru.ru/excel/funkcija-schetz-excel-28.html
    • https://excel2.ru/articles/funkciya-bschyot-podschet-s-mnozhestvennymi-usloviyami-v-ms-excel-bschyot
    • https://yandex.ru/q/question/kak_funktsioniruet_funktsiia_bschet_v_322b1330/
    • https://excel2.ru/articles/podschet-pustyh-yacheek-v-ms-excel
    • https://exceltable.com/formuly/schetz-i-schitatpustoty
    • https://lk.usoft.ru/allfunction/f_Excel/f_e_20150713
    • https://mister-office.ru/funktsii-excel/function-countif.html
    • https://my-excel.ru/vba/schet-pustyh-jacheek-v-excel.html
    • https://officelegko.com/2020/03/17/kak-poschitat-kolichestvo-pustyh-i-nepustyh-yacheek-v-eksel/
    • https://artemvm.info/information/uchebnye-stati/microsoft-office/funkcziya-schetz-v-excel/
    • https://exceltable.com/funkcii-excel/schet-schitatpustoty-schetesli
    • https://lumpics.ru/count-function-in-excel/

    Рейтинг
    ( Пока оценок нет )
    Понравилась статья? Поделиться с друзьями:
    Все об Экселе: формулы, полезные советы и решения